The MidnightBSD Ports Collection (/usr/mports/www/qt5-websockets-qml)

You are now in the directory for the port "/usr/mports/www/qt5-websockets-qml".

The package name of this port is "qt5-websockets-qml-5.13.2".

This is the one-line description for this port:

Qt implementation of WebSocket protocol (QML bindings)


Please read the "description file" for a longer description and/or visit the web site for futher informations.

If needed, you may contact the maintainer of this port or the port mailing-list.

This port requires package(s) "ca_root_nss-3.52_1 cairo-1.15.12,2 dbus-1.10.16_1 etc_os-release-0.1 expat-2.2.8 fontconfig-2.13.92_2,1 freetype2-2.9.1 gettext-runtime-0.20.2 glib-2.56.3_2,1 graphite2-1.3.13 harfbuzz-1.9.0 hicolor-icon-theme-0.17 icu-65.1,1 indexinfo-0.3.1_1 jpeg-turbo-2.0.3 libICE-1.0.10 libSM-1.2.3,1 libX11-1.6.9_1,1 libXau-1.0.9 libXdamage-1.1.5 libXdmcp-1.1.3 libXext-1.3.4,1 libXfixes-5.0.3_3 libXi-1.7.10,1 libXmu-1.1.3,1 libXrender-0.9.10_2 libXt-1.2.0,1 libXxf86vm-1.1.4_2 libdrm-2.4.99,1 libedit-3.1.20181209_2,1 libepoll-shim-0.0.20200602 libevdev-1.5.9 libffi-3.2.1_1 libgudev-230_1 libiconv-1.14_14 libinput-1.15.5 libmtdev-1.1.5_1 libpciaccess-0.16 libpthread-stubs-0.4 libudev-devd-0.4.2 libunwind-20170615_1 libwacom-1.3 libxcb-1.13.1_1 libxkbcommon-0.10.0 libxml2-2.9.10_1 libxshmfence-1.3 llvm70-7.0.1 mesa-libs-19.0.8 openssl-1.1.1g_1,1 pciids-20200421 pcre-8.43 pcre2-10.33 pixman-0.40.0 png-1.6.37 py27-six-1.13.0 py37-evdev-0.8.1_1 py37-pyudev-0.22.0 py37-setuptools-44.0.0 python27-2.7.18_1 python37-3.7.7 qt5-buildtools-5.13.2_1 qt5-core-5.13.2_2 qt5-dbus-5.13.2_1 qt5-declarative-5.13.2 qt5-gui-5.13.2_1 qt5-network-5.13.2_2 qt5-qmake-5.13.2_2 qt5-sql-5.13.2_1 qt5-testlib-5.13.2_1 qt5-websockets-5.13.2_1 qt5-widgets-5.13.2_1 qt5-xmlpatterns-5.13.2 qtchooser-66 readline-8.0.0_1 vulkan-headers-1.1.108.0 xcb-util-0.4.0_2 xcb-util-image-0.4.0_1 xcb-util-keysyms-0.4.0 xcb-util-renderutil-0.3.9_1 xcb-util-wm-0.4.1_2 xdg-utils-1.1.3 xkeyboard-config-2.29 xorgproto-2020.1 xprop-1.2.4 xset-1.2.4_3" to build.

This port requires package(s) "ca_root_nss-3.52_1 cairo-1.15.12,2 dbus-1.10.16_1 etc_os-release-0.1 expat-2.2.8 fontconfig-2.13.92_2,1 freetype2-2.9.1 gettext-runtime-0.20.2 glib-2.56.3_2,1 graphite2-1.3.13 harfbuzz-1.9.0 hicolor-icon-theme-0.17 icu-65.1,1 indexinfo-0.3.1_1 jpeg-turbo-2.0.3 libICE-1.0.10 libSM-1.2.3,1 libX11-1.6.9_1,1 libXau-1.0.9 libXdamage-1.1.5 libXdmcp-1.1.3 libXext-1.3.4,1 libXfixes-5.0.3_3 libXi-1.7.10,1 libXmu-1.1.3,1 libXrender-0.9.10_2 libXt-1.2.0,1 libXxf86vm-1.1.4_2 libdrm-2.4.99,1 libedit-3.1.20181209_2,1 libepoll-shim-0.0.20200602 libevdev-1.5.9 libffi-3.2.1_1 libgudev-230_1 libiconv-1.14_14 libinput-1.15.5 libmtdev-1.1.5_1 libpciaccess-0.16 libpthread-stubs-0.4 libudev-devd-0.4.2 libunwind-20170615_1 libwacom-1.3 libxcb-1.13.1_1 libxkbcommon-0.10.0 libxml2-2.9.10_1 libxshmfence-1.3 llvm70-7.0.1 mesa-libs-19.0.8 openssl-1.1.1g_1,1 pciids-20200421 pcre-8.43 pcre2-10.33 pixman-0.40.0 png-1.6.37 py27-six-1.13.0 py37-evdev-0.8.1_1 py37-pyudev-0.22.0 py37-setuptools-44.0.0 python27-2.7.18_1 python37-3.7.7 qt5-core-5.13.2_2 qt5-dbus-5.13.2_1 qt5-declarative-5.13.2 qt5-gui-5.13.2_1 qt5-network-5.13.2_2 qt5-sql-5.13.2_1 qt5-testlib-5.13.2_1 qt5-websockets-5.13.2_1 qt5-widgets-5.13.2_1 qt5-xmlpatterns-5.13.2 qtchooser-66 readline-8.0.0_1 vulkan-headers-1.1.108.0 xcb-util-0.4.0_2 xcb-util-image-0.4.0_1 xcb-util-keysyms-0.4.0 xcb-util-renderutil-0.3.9_1 xcb-util-wm-0.4.1_2 xdg-utils-1.1.3 xkeyboard-config-2.29 xorgproto-2020.1 xprop-1.2.4 xset-1.2.4_3" to run.

Go to the top of the ports tree for a summary on how to use the ports collection.


Go up one level | Go to top of ports tree